Accueil des Plug-ins K!TV XP

Accueil

Aide aux Plugins pour K!TV XP

Version 0.6 (02/07/2002)

Les plug-ins décrits dans cette aide
sont tous sous licence GPL
(en anglais et en français)


Plug-in Vidéo - Albator

- "Options" => "Albator" => "Réglages Décodage"

- Raccourci clavier Ctrl + F3

- Ou alors cliquer sur l'image avec le bouton droit de la souris (ouverture du menu contextuel) => "Albator" => "Réglages Décodage"

Options de Décodage | Explications
Couples | Nombre de lignes de l'image sur lesquelles la reconstruction de l'image est tentée. Plus ce nombre est élevé, plus la consommation processeur sera grande. En revanche, le décodage décrochera moins dans le traitement des images difficiles (images sombres ou d'une couleur uniforme).
Autres nombres de couples | Série de couples proposés qui pourront être utilisés par la suite avec les commandes L et CTRL+L
Utiliser les deux trames | Il y a deux demi-images : l'une contenant les lignes paires et l'autre les lignes impaires. Le résultat est bien meilleur si on traite les deux demi-images plutôt qu'une seule. Par contre il y a un surcoût en consommation CPU. (Touche TAB)
Pour les petits processeurs, il y a débat entre les utilisateurs de beaucoup de couples et d'une seule demi image contre les deux demi-images et peu de couples. Avec 1 GHz, la question ne se pose pas : couples à 80 et double trame de rigueur.
Fix Chipset VIA et sa résolution en x | Quel problème compliqué. Voir ICI pour toutes les explications. Plus la résolution en x est élevée, moins le "fix" va agir, moins vous dégraderez l'image, et plus vous rencontrerez les problèmes de saturation, car le but est de dégrader pour moins saturer. Le réglage idéal (image la moins dégradée) est le réglage le plus haut pour lequel les lignes noires ne sont plus présentes. Au fait, à 768, le fix n'agit plus. (logique)
PAL Plus Actif pendant le décodage | Lors d'une émission PAL une ligne spécifique est émise. C'est la ligne PAL plus. En France (le royaume du SECAM) elle est inutile, ce qui n'est pas le cas en Allemagne ou en Espagne ou elle est alors utilisée pour le déschtroumphage. Cette case ne sert à rien à ma connaissance, corrigez moi si je me trompe.
Seuil des Lignes Noires | Une des particularités d'une émission est d'être émise en 4:3, 16:9 ou 20:9. Dans le cas des deux dernières il y a donc présence de deux bandeaux de lignes noires en haut en en bas. Ce paramètre permet de définir si une ligne doit être considérée comme appartenant à ces bandeaux ou non lors du déschtroumphage. Comme cela K!Tv n'aura pas à traiter ces lignes et on gagnera donc en occupation CPU.
Détection Automatique Codage | Utilisation des données télétexte pour déterminer si le signal est encodé ou non. Comme toute donnée transmise en numérique, cette option est très sensible à la qualité de réception qui se doit d'être optimale. Dans le cas contraire cette option ne sera pas très efficace et il peut être nécessaire de forcer le décodage avec l'option "Forcer décodage" (alt+f3) dans le cas d'une instabilité de la détection.

Réglage du Filtre SECAM | Explications
Seuil U | Schématiquement U correspond à la composante bleue de l'image. Si la couleur d'un point de l'image est supérieure à chacun des 3 seuils, le point est considéré comme ayant une couleur saturée et est alors traité par le filtre dit "lignes bleues". La meilleure valeur possible de ces paramètres est la valeur la plus élevée pour laquelle on n'observe pas de dégradation.
Seuil V | Pareil pour rouge
Seuil Vert | Pareil pour vert
Seuil Pix | Le seuil Pix correspond au pourcentage maximum de pixels non saturés autorisé dans une ligne saturée. La meilleure valeur possible de ce paramètre est la valeur la plus basse pour laquelle on n'observe pas de dégradation.

- Pour un BT878 il est conseillé 63/63/43/20
- Pour un BT848, il est conseillé 100/100/100/20
- Rien ne sert de toucher à ces réglages (très complexes) si l'image ne bave pas. Les réglages qu'albator met par défaut sont les meilleurs.

- Mais alors comment régler le filtre anti-bavures ?
Le filtre anti-bavures n'a pas besoin de réglages indépendants.
En revanche, les réglages de la boite de dialogue des filtres Secam influent sur le comportement du filtre anti-bavures.
Pour le meilleur résultat possible du filtre anti-bavures, le filtre "lignes bleues" doit être réglé de façon optimale, c'est à dire de telle sorte qu'il élimine le plus possible de lignes saturées sans trop faire de fausses détections.
D'où les paramètres proposés plus haut en fonction du chipset.

Le Menu Albator

Le menu qui est appelé par le clic droit de la souris (-> décodage)est le même que celui du menu général :

Action | Raccourci clavier | Explications
Décodage | F3 | Permet de lancer le traitement vidéo
Forcer Décodage | Alt+F3 | Lorsque le décodage est en mode automatique, parfois il n'est pas stable. Cette option permet de forcer le traitement vidéo
Pas de Décodage | F2 | Pas de traitement vidéo sur le signal en cours de capture
Filtre Anti-Bavures | F | Activation / Désactivation du filtre SECAM Anti-Bavures
Filtre Lignes Bleues | Ctrl+F | Activation / Désactivation du filtre SECAM supprimant les lignes bleues et rouges, ce filtre est inutile pour les BT848 (il est désactivé par défaut avec ces chipsets)
Commuter Phase Anti-Bavures | P | Lorsque le filtre Lignes Bleues n'est pas synchronisé cette option permet de forcer la synchronisation


Plug-in Audio - Chorus

- "Options" => "Chorus" => "Réglages décodeur audio"

- Ou alors cliquer sur l'image avec le bouton droit de la souris (ouverture du menu contextuel) => "Chorus" => "Réglages décodeur audio"

Options | Explications
Nombre de Buffers | Espaces mémoire dans lesquels le déschtroumphage audio est réalisé
Taille des Buffers | Taille de ces espaces mémoire
Filtres: Préfiltre | Filtrage du signal avant déschtroumphage
Filtres: Postfiltre | Filtrage du signal après déschtroumphage
Priorité du décodage sonore | Dans certains cas où le CPU est un peu juste, si le son traité est haché il peut être intéressant de donner plus de priorité à ce traitement qu'à d'autres
Amplification du Buffer de Sortie | Augmentation du niveau de sortie sonore après traitement du son
Fréquence d'échantillonnage | Souvent la fréquence d'échantillonnage est à 44 khz mais cela peut être légèrement différent. d'ou la possibilité d'en choisir une autre (44Khz correspond au format CD Audio Stéréo). Pour les cartes son ISA la fréquence doit être de 25600 et pour certaines cartes récentes on peut monter à 48KHz
Pitch | Décalage de la fréquence d'échantillonnage d'un peu plus ou d'un peu moins
Synchro Auto Son / Vidéo | Lancer automatiquement le décryptage du son lors du démarrage du décryptage vidéo

Alors on va pas le cacher.
Les plug-ins audio associés au mixer de K! sont les points faibles de K!TV XP actuellement. On rencontre énormément d'utilisateurs qui ne réussissent pas à décoder le son et qui utilisent alors un décodeur externe tel que CplusWin ou Wilma. C'est pourtant faisable ! Rendez-vous à la section Plug-ins Audio : mode d'emploi pour essayer d'y voir plus clair.


Plug-in vidéo - Cricrack

En cas de problèmes, rendez vous aux FAQ des Plugins Video.

Ce plugin fonctionne pour C+ Belgique et France Télécom câble analogique, donc pour le codage appelé "Discret" qui a été le premier principe de C+ France, avant le Nagra ; il consiste à réaliser des décalages de début de ligne (pas de 880 ns). Ils peuvent fonctionner dans tous les pays où ce codage est utilisé (France, Belgique...). Vous pouvez retourner à l’Introduction pour voir le tableau sur les plug-ins.

Quelques explications du plugin CriCrack 0.8.x : Par Cricri
- Ce plugin est basé sur la version Azertix 9c et sur More FTC.
- Le principe est la corrélation par répartition + corrections : le décodage se fait par corrélation simple trame et trame entrelacée, et différentes méthodes de corrélation sont utilisées, mais toutes basées sur Azertix9c ( pour BorgTV ).
- Décodage par clé (polynome) uniquement pour FTC, s'active automatiquement si l'option " détection automatique " est activée. Si la détection automatique est activée, le truc bascule en mode clé si une chaîne FTC est trouvée. Ceci peut-être désactivé par CTRL F4.
- La résolution de capture doit être comprise entre 720 et 768, le meilleur étant 754.
- Fonctionne très mal en mode DIB.
- Décodage mauvais si le VIA_FIX est activé... Normal, sa capture, réso en x optimale étant le 754.
- En déco par algo, donc pour FTC, il vaut mieux élever la priorité de programme K!TV sous peine de perte de Frame, à priori, car le truc décroche de temps à autre, ça n'arrive qu'en mode fenêtré...
- Le mode algorythmique par clé fonctionne chez Cricri, mais ce n'est pas certain qu'il fonctionne partout de la même manière, ni même dans le temps.
- Le gel d'image ne fonctionne pas en mode clé.
- Rappel : La résolution de capture horizontale optimale est de 754
- Comme les autres plugins, activation par F3, désactivation par F2, une fois bien sûr le plugin déclaré dans K!TV.

Configuration

- "Options" => "Cricrack" => "Réglages du Décodage Video"

- Raccourci clavier Ctrl + F3

- Ou alors cliquer sur l'image avec le bouton droit de la souris (ouverture du menu contextuel) => "Cricrack" => "Réglages du Décodage Video"

Les options sont décrites ci-dessous. Mieux vaut ne pas y toucher, les réglages par défaut étant les meilleurs. Si vous êtes un bêta testeur, jetez-y un oeil et aidez Cricri à développer son plug-in pour le bien de nos amis "Discrets".

Options de Décodage | Explications
Modes de fonctionnement : Utilisation d'une seule trame (paire je pense) auquel cas les 3 autres options sont inactives, sinon 3 modes apparaissent :
- Automatique : choisit le mode approprié parmi les 2 suivants (plus gourmand en CPU)
- Trame par trame : la corrélation est effectuée entre lignes de même parité. Meilleure pour les mouvements puisqu'il n'y a pas de décalage dans le temps.
- Trame entrelacée : La corrélation est effectuée entre lignes de parité différente.
Meilleure en abcence de mouvement car plus fine.
Principes de décodage : En automatique :
Le programme, dans sa version courante, effectue 3 corrélations par mode de fonctionnement (donc 6 en mode de fonctionnement automatique) et essaye de déterminer la meilleure méthode. Ceci est donc le plus gourmand en CPU. Les méthodes testées sont Azertix standard, Cricrac standard et Cricrac avec les options corrections et corrélation.

En manuel :
il est possible de choisir entre Azertix et CriCrac, plus quelques options.

- Azertix 9c : ce mode est censé se rapprocher le plus possible de l'original.
Les options sont :
. début ligne : même option que dans l'original, pas très fiable comme toute détection de début de ligne, mais donne tout de même parfois de bons résultats.
. shift 2 : bientôt supprimée

- CriCrac : Très similaire à Azertix, mais les seuils sont différents et réglables (correction minus).
. Correction plus : ajoute une correction positive, similaire à une détection de début de ligne, mais plus faible. Les niveaux de détection du noir et de correction sont réglables.
. Corrélation sur l'option précédente, c'est à dire que l'on corrèle avec le début de ligne précédent, cela permet de corriger certaines erreurs.
Détection Automatique Codage | Utilisation des données télétexte pour déterminer si le signal est encodé ou non. Comme toute donnée transmise en numérique, cette option est très sensible à la qualité de réception qui se doit d'être optimale. Dans le cas contraire cette option ne sera pas très efficace et il peut être nécessaire de forcer le décodage avec l'option "Forcer décodage" (alt+f3) dans le cas d'une instabilité de la détection.

Réglages (Debug Purpose) | Explications
Offset X | C'est l'Offset en pixel par rapport au début de ligne. 1 pixel donne de bons résultats dans l'ensemble. Ceci décale l'image vers la gauche.
Nombre de points | C'est le "step" pour la corrélation par répartition. De base 13 pixels, ce qui correspond à un décalage, normalement n'a pas a être changé. Plus on le diminue, plus ça charge le CPU, mais meilleure est la corrélation.
Niveau Black début et les différentes corrections | Ce sont les réglages de détection du niveau de noir et de correction, positifs et négatifs. - Une valeur supérieure dans la détection de niveau de noir (+/-) augmente le seuil - Une valeur supérieur dans la correction (+/-) diminue celle-ci (je sais, pas très logique ...)

Même si toutes ces options ont des valeurs par défaut, il peut être intéressant de passer en mode gelé et d'essayer quelques options/réglages, d'informer des résultats, surtout en cas de répétabilité, et d'envoyer les résultats ainsi que l'image (zippés) à Cricri.


Plug-in Vidéo - KAzertix

En cas de problèmes, rendez vous aux FAQ des Plugins Video.

Ce plugin fonctionne pour C+ Belgique et France Télécom câble analogique, donc pour le codage appelé "Discret" qui a été le premier principe de C+ France, avant le Nagra ; il consiste à réaliser des décalages de début de ligne (pas de 880 ns). Ils peuvent fonctionner dans tous les pays où ce codage est utilisé (France, Belgique...). Vous pouvez retourner à l’Introduction pour voir le tableau sur les plug-ins.

Quelques explications sur les plugins KAzertix :

1) KAzertix03d : Par Azertix (déjà auteur de plug-in pour BorgTV).

La technique du décodage se fait par corrélation de lignes d'une même trame (trame par trame).
Cette technique est probablement meilleure lors de mouvements.

2) KAzertix04c : Par Azertix

Le décodage se fait par corrélation de lignes trame paire et impaire (trame entrelacée). Cette technique est probablement meilleure sans trop de mouvement.

3) KAzertix02b : Par Azertix

Le décodage se fait par clé (polynôme), et uniquement pour la chaîne RAI en Belgique.

Configuration

- "Options" => "KAzertix*" => "Réglages Décodage Video"

- Raccourci clavier Ctrl + F3

- Ou alors cliquer sur l'image avec le bouton droit de la souris (ouverture du menu contextuel) => "KAzertix*" => "Réglages Décodage Video"

Pas beaucoup d'options.
De plus, cette option n'est pas disponible dans KAzertix 02 b.
Les KAzertix ne fonctionnent qu'en FULLFIELD (double trame, tapez [Tab] si vous n'y êtes pas), et en résolution de capture 754.


Plug-in Audio - Kiwicricri

-"Options" => "Kiwicricri" => "Réglages décodeur audio"

- Raccourci clavier Ctrl + F4

- Ou alors cliquer sur l'image avec le bouton droit de la souris (ouverture du menu contextuel) => "Décodage" => "Réglages décodeur audio"

Options | Explications
Nombre des tampons | Espaces mémoire dans lesquels le décodage audio est réalisé
Taille des tampons | Taille de ces espaces mémoire
Fréquence d'échantillonnage : échantillonnage | Souvent la fréquence d'échantillonnage est à 44 khz mais cela peut être légèrement différent. d'ou la possibilité d'en choisir une autre (44Khz correspond au format CD Audio Stéréo). Pour les cartes son ISA la fréquence doit être de 25600 et pour certaines cartes récentes on peut monter à 48KHz
Fréquence d'échantillonnage : démodulation | C'est le codage de canal + qui fait que la démodualtion est à 12800 hz. Donc, toucher cette valeur ne sert théoriquement à rien. En pratique, modifier de quelques dizaines de hertz permet de supprimer un bruit de fond super aigü.
Filtre de 3ème ordre : passe-bas | Pas terrible pour l'instant, mettre le nombre de passes à 0 pour le désactiver. CRICRI : modifie toi-même les explications, je n'y connais rien...
Filtre de 3ème ordre : nombre de passes | Pas terrible pour l'instant, mettre 0 pour le désactiver. CRICRI : modifie toi-même les explications, je n'y connais rien...
Priorité du décodage sonore | Dans certains cas où le CPU est un peu juste, si le son traité est haché il peut être intéressant de donner plus de priorité à ce traitement qu'à d'autres, à tester...
Amplification | Augmentation du niveau de sortie sonore après traitement du son.
Synchro Auto Son / Vidéo | Lancer automatiquement le décryptage du son lors du démarrage du décryptage vidéo

On rencontre énormément d'utilisateurs qui ne réussissent pas à décoder le son et qui utilisent alors un décodeur externe tel que CplusWin ou Wilma. C'est pourtant faisable ! Rendez-vous à la section Plug-ins Audio : mode d'emploi pour essayer d'y voir plus clair.

Ce plug-in est à l'état de bêta test... Certains réglages sont temporairement inaccessibles, volontairement de la part du dévelo. Donc cela veut dire qu'il faut que vous l'expérimentiez et que vous fassiez des retours sur utilisation au développeur sur le forum adéquat (cf la page des liens).


Plug-in Vidéo - MeuhMeuhPlug

Meuhmeuhplug est actuellement le meilleur plug-in de décodage de canal+ Nagra K!TV XP, alors qu'il est le plus jeune...
Pour info, c'est Fasouil, créateur et développeur principal de meuhmeuhTV, qui a adapté ses algos de décodage à un plug-in pour K!TV. En plus, il a le culot de les avoir encore optimisés.

Notes particulières :

Consommation CPU :
Dans la barre d'état (quand k!tv est en mode fenêtré) apparaît la conso CPU ; elle est un peu différente de celle de la barre des tâches de Windows, parce qu'elle ne montre que ce que consomme le plug-in. En tout cas, ça décoiffe...

Défauts :
Certaines personnes rencontrent des problèmes faisant penser au Fix chipset via. Il manque peut-être un fix chipset Via au meuhmeuhplug, bien que baisser la "capture, réso en x" soit une solution équivalente, mais qui s'applique à toutes les chaînes.

Installation

a) Placez le fichier key.txt dans le sous-répertoire de K!TV : plug-ins
b) Placez dans ce même répertoire le fichier MeuhMeuhPlug.dll et les deux fichiers FPC livrés dans l'archive zip
c) Lancez K!TV, placez vous sur le bon canal (hihi), puis installez le plugin MeuhMeuhPlug (pour les nuls, cf la page d'installation)
d) Ne touchez pas les 2 valeurs d'itérations maximum, (celles par défaut sont très bien), appuyez sur OK pour générer les 6 fichiers FPC
e) La génération des fichiers fpc prend un certain temps, ne vous inquiétez pas.

Dorénavant, le changement des valeurs d'itérations ne nécessite plus une nouvelle génération des fichiers fpc. Merci fasouil...

Configuration

Normalement, la boîte de réglages s'ouvre toute seule au premier lancement, si vous avez suivi les instructions au-dessus.

Sinon : "Options" => "Meuhmeuhplug" => "Réglages..."

Ou alors cliquer sur l'image avec le bouton droit de la souris (ouverture du menu contextuel) => "MeuhmeuhPlug" => "Réglages..."

Options | Explications | Raccourci clavier
Nombre d'itérations maximum Ces valeurs sont mises par défaut lors du premier lancement de meuhmeuhplug. Sinon, voilà le tableau :

Fréquence réelle | Image en mouvement | Plan fixe
1,5 GHz | 21 | 15
1,2 GHz | 17 | 12
900 Mhz | 13 | 9
600 MHz | 9 | 6

Techniquement :
MeuhMeuhPlug arrive à trouver la clef avec 1 seul test sur une image facile. Sur les images difficiles, il faut parfois plusieurs tests. C’est ce nombre maxi de tests (itérations, répétitions des tests) qui est réglé dans la boite de dialogue.
Attention :
si le nombre d’itérations est trop grand, MeuhMeuhPlug passera beaucoup de temps sur chaque image. Ce trop grand temps se traduit par la perte de l’image suivante, et donc par le décrochage du décodage.
Alors les bourrins, pas besoin de tout mettre à fond. 		réglable uniquement par la boîte dialogue
Double trame Réglage spécifique à tous les plugins videos. Par défaut, on est en double trame, c'est-à-dire que l'image affichée correspond à celle que l'on reçoit, en fait deux demi-images de 768*288 pixels.
Décocher la case fait passer l'affichage en simple trame. A quoi ça sert la simple trame ? En simple trame, le décodage prend beaucoup moins de ressources, puisque seule une des deux demi-images est filtrée et affichée.
Ce réglage ne doit pas être très utile, vu le peu que consomme meuhmeuh.
Au fait, en simple trame, le désentrelacement ne sert à rien, hein... 		TAB
Filtre anti-bavures | C'est un filtre contre les bavures liées au Secam. Donc normalement utile sur toutes les configs. | F
Filtre lignes violettes C'est le fameux filtre ligne bleues qui est aussi utilisé par les plugins albator. Les lignes bleues concenées sont celles qui apparaissent pour les bt878.
Pour info, fasouil utilise les lignes bleues pour décoder une image sur 3 sans calcul, ce qui fait que le décodage avec un bt878 prend 30% de temps en moins qu'avec un bt848. Ne pas utiliser ce filtre avec un bt848. 		Ctrl + F
Filtre moyenneur Toute une technique pour rendre l'image jolie.
Fortement déconseillée par Fasouil, décriée, cette option qui rappelons-le annule toutes les optimisations qui font la force du MMplug, est à utiliser selon votre bon vouloir. 		Alt + F
Forcer le décodage | Bah ça peut être utile pour ceux qui ont des problèmes de stabilité, ça force le décodeur. | Alt + F3
Réglages... | Permet d'accéder à la boîte de dialogue | Ctrl + F3
Aide aux plugins | Permet d'accéder au fichier d'aide aux plugins "aideplugin.chm" que vous êtes en train de lire en ce moment. Ce fichier doit être placé dans le sous-répertoire de k!tv : aide | Ctrl + F1


Enregistrement - Zoomout

Page en Construction

Cette page n'a pas été construite !

Vous aussi aidez nous à construire cette page !

Nous avons besoin de vos aides, alors n'hésitez pas à nous mailer à :

 aideplugin@ifrance.com

Car s'il ne doit rester qu'un maître dicton :
l'entraide est notre force à tous !


Généralités - FAQ générale

1) A quoi servent les fichiers *.ini ?
2) Problèmes à la con...
3) Surcharge cpu, ralentissements, saccades...
4) Différence intel, vcc ...
5) A propos de la légalité...

1) A quoi servent les fichiers *.ini ?

Ce sont les fichiers de configurations des plug-ins (DLLs). Si la configuration via les boîtes de dialogue ne fonctionne pas correctement (problème qui n'est actuelement plus rencontré), il est alors interessant de faire la configuration directement dans les fichiers ini puis si nécessaire de les passer en attribut "read-only".

2) En cas de problèmes incompréhensibles

(avant tout marchait bien, et maintenant j'ai une sur-conso processeur…)
Il existe des manipulations pas très catholiques qui consistent à supprimer, dans le répertoire de K!TV XP, les fichiers *.dll que l’on n’utilise pas ainsi que tous les *.ini . C’est bien souvent salvateur…

3) Problèmes de surcharge cpu, de ralentissements du décodage, de saccades

Enormément de paramètres sont à prendre en compte :
- Tout d'abord vérifier que le mode Overlay est bien activé. Il est bien plus efficace que le mode DIB dont l'utilisation est restreinte à quelques utilisateurs et possesseurs de vieilles bécanes.
- Vous pouvez baisser la qualité des réglages de votre plug-in video. Rendez vous à la section du plugin concerné, et à la FAQ des Plugins Video
- Vous pouvez baisser la résolution en x, qui aura pour effet de diminuer l'image et de favoriser le décrochage du décodeur.
- Votre PC est dégueulasse : vous avez déjà installé 12000 pilotes, vous avez 15000 applications qui tournent en même temps que K!TV XP, vous avez installé les 13 versions précédentes de K!TV XP en écrasant les fichiers précédents. Bref, vous êtes un porc. Désinstallez, K!TV, tous vos drivers à la rigueur (il est bon de noter que K!TV XP n'a pas besoin des pilotes du Tuner TV pour fonctionner…). Surtout, il faut que rien des précédentes versions de K! ne reste. Vous réinstallez proprement, vous supprimez les *.dll que vous n'utilisez pas (dixit Quenotte) et ça devrait aller mieux. La meilleure solution c'est évidemment le formatage.
- Vous avez un Pentium 100 : il est à noter qu'à partir de 500 MHz on déschtroumpfe sans saccade. A 1 GHz, tout à fond et sans saccade.
- Vous n'utilisez pas la bonne technique de désentrelacement : testez toutes les techniques de désentrelacement en regardant les ressources processeur, et même n'en utilisez pas, beaucoup de gens possèdent des cartes graphiques qui supportent mal le désntrelacement.

4) Certains plugins sont disponibles en 2 versions : une normale et une "VCC", quelle est la différence ?

La normale est compilée avec Intel C++ Compiler et la VCC est compilée avec Microsoft Visual C++.
Cette dernière est celle qu'il faudra utiliser avec la version VCC de K!TV.
Il faut utiliser la version VCC si des soucis sont rencontrés avec la version normale de K!TV (message d'erreur au démarrage par exemple, bug connu avec les PC munis d'un processeur AMD de la gamme K6-X).
Si aucun problème n'est rencontré, en théorie le compiler d'intel réalise plus d'optimisations, donc cela "devrait" être la version la plus rapide. Ceci peut se vérifier en mesurant le cpu consommé.

5) Les plug-ins sont-ils des fichiers légaux ?

L'intérêt du reverse engineering est de reproduire le comportement d'un système (soft ou hard), sans en repomper une ligne de code...
Ce qui signifie que les droits et copyrights ne s'y appliquent pas...
Albator ne tiendrait pas du reverse engineering car les algo utilisés n'ont rien à voir avec ceux du décodeur officiel. Albator est une attaque du système officiel par un moyen détourné. Par exemple, le concept d'entropie dans une image n'est pas utilisé dans le décodeur officiel.
Toujours est-il que sans la clef, les plugins ne sont pas illégaux en soi, car ils ne reprennent ni les algos ni le code officiel, alors qu'avec...


Plug-in Vidéo - FAQ Vidéo

1) Petite config
2) La clé...
3) Décodage automatique...
4) Génération des fichiers lors du premier décodage...
5) Le MovieBoost (Bandes Noires)
6) Evaluer la qualité du plugin video...
7) Décrochages sur images sombres
8) Décrochages sur plein d'images

1) J'ai une petite config, comment optimiser le décodage ?

1) Avoir une bonne réception (et tout plein d'autres conseils dans la Faq faire fonctionner)
2) Passer en simple trame (touche [TAB])
3) Capturer avec une résolution horizontale de 512 pixels. ("bouton droit", "affichage", "capture, réso en x")
4) Optimiser les paramètres de la RAM (contrôlez la bande passante avec Sandra par exemple)

2) Que se passe-t-il si je ne mets pas la clé ?

Vous n'avez pas la clé, ce n'est grave ni pour le plugin Cricrack ni pour les plugins KAzertix qui l'intègrent dans leur dll. Si vous n'avez pas la clé sous la forme "key.txt" dans le répertoire de K!TV XP/Plugins, vous obtenez ces messages :

Je me permets d'insister sur le fait que cette question est posée 2 fois par jour sur les forums par des utilisateurs qui ne cherchent pas très très loin...
C'est simple :
- Où trouver ce fichier clé ?
Désolé, mais là faut chercher. Utilisez Google, ça devrait aller.
- Y a-t-il différentes versions ?
Il y a une version pour le c+ Hertzien Nagra, et une version ("key_c.txt") pour le c+ Sat Nagra. Cette dernière est celle de Multidec. Elle ne peut fonctionner que si elle est renommée en "key.txt".
-Bon, OK, mais comment je sais quelle clé utiliser ?
Rendez vous à l'Introduction ICI.

3) Le déschtroumpfage automatique ne fonctionne pas correctement ?

Vérifiez tout d'abord que la réception soit impeccable. Le signal de codage étant transmis sous forme numérique il est très sensible au phénomène de fading qui comme chacun le sait est, pour le numérique, pas des parasites mais une coupure nette du signal. Pour lancer le décodage video, faites F4. Si cela ne marche toujours pas, vous pouvez forcer le décodage (alt+F4).

4) Génération des fichiers lors du premier décodage ?

Lors du premier déschtroumpfage, pour albator comme pour Meuhmeuhplug, il faut laisser le temps au soft de générer des fichiers : les *.idx pour Albator, et les *.fpc pour Meuhmeuhplug. Ce sont des tables nécessaires au déschtroumpfage et créées avec la clé (voilà pourquoi il vous faut la clé lors du premier décodage). Ces fichiers sont différents : selon le nombre de couples pour Albator, et selon le nombre d'itérations pour Meuhmeuhplug (cf les pages de config respectivement ICI et ICI.
Si vous ne changez jamais les valeurs de votre plugin video, vous pouvez les garder et les recopier pour une autre installation, plutôt que de les régénérer. D'ailleurs, quelques fichiers sont fournis avec MMPlug (clé commune et réglages par défaut).

5) Le plugin Video rame pendant les 20-30 premières secondes après que j'ai activé le décodeur. Que se passe-t-il ?

Ceci est dû à la recherche automatique des bandes noires (aussi appelée movieboost).
Le movieboost permet d'accélérer grandement le décodeur dans les films en 16/9, et de rajouter des bandes noires bien plus propres que les bandes décodées. La recherche automatique des bandes noires est donc conseillée.
Vous pouvez tout de même désactiver la recherche automatique des bandes noires dans "Affichage" / "Bandes noires (cinémascope)", en désactivant l'option "Auto".

6) Comment apprécier la qualité du décodage pour tester les différents plug-ins vidéos, leurs divers réglages et les techniques de désentrelacement ?

1er facteur : la consommation cpu : Comment la visualiser ?
- Sous Windows 9x/Me : En utilisant le Vu-mètre ressources fourni par le CD d'installation de Windows ; si le Vu-mètre est installé, vous le trouverez dans "Démarrer" => "Programmes" => "Accessoires" => "Outils système"
Vous pouvez aussi utiliser Wintop, un logiciel qui est dédié au visionnage de la conso CPU (cf la page des liens).
- Sous Windows 2000/XP : Ouvrez le gestionnaire des tâches (bouton droit sur la barre des tâches, ou simplement ctrl+alt+suppr) pendant le fonctionnement de K!TV XP et cliquez sur l’onglet "Performances".
Visionner la conso CPU permet d'excellents tests, car une conso cpu à 100 % va entraîner un décrochage du déschtroumpfage, et car plus un réglage consommera en ressources, moins K!TV sera fluide.
- Avec le plug-in "Meuhmeuhplug" : il intègre lui-même un compteur de conso CPU visible dans la barre des tâches :

2ème facteur : le compteur ips de K!TV XP : (ips = images par seconde). Son principal inconvénient est qu’on ne peut pas l’utiliser en mode plein écran, et qu'en plus de tels compteurs ne permettent pas d'apprécier les microsaccades.

3ème facteur : Le match de foot ! Un travelling sur un terrain de foot (dégagement du gardien par exemple) est très gourmand en ressources processeur. Donc, si le ballon a une trajectoire fluide, c’est bon, vous pouvez augmenter les paramètres du déschtroumpfage. De plus, la propreté du piqué d’un joueur de foot (un petit truc noir sur un fond vert) permet d’apprécier la qualité du plug-in de désentrelacement.

7) Dés que l'image est trop sombre, l'image saccade terriblement, le deschtroumpfage et le filtre bleu décrochent. A quoi cela est dû ?

Si seulement le filtre bleu décroche, c'est dû à la dernière version du filtre qui privilégie le bon filtrage des lignes bleues sans détérioration des couleurs (c'est à dire, ne filtre pas, à tort, les lignes très colorées). L'inconvénient, c'est qu'il décroche effectivement plus facilement quand l'image est sombre.
Ce problème n'est pas présent avec MMplug.
Pour Albator, si c'est bien le déschtroumpfage qui décroche (cela fait donc aussi décrocher le filtre de Snabrab), là il n'y a pas d'autres solutions que d'augmenter le nombre de couples.
le déschtroumpfage d'Albator se sert d'un principe "simple" : on prend des couples de lignes et on regarde si deux lignes sont fortement ressemblantes au niveau de la luminance. Si elles sont ressemblantes cela veut dire qu'elles sont voisines l'une de l'autre. Cela permet donc de retenir la bonne permutation des lignes pour obtenir une image claire.
Le problème sur une images sombre (noire) c'est que presque toutes les lignes se ressemblent (car elles sont noires) et cela ne permet plus à l'algorithme de sélectionner la bonne permutation pour déstroumpfer : l'image est alors mal déschtroumpfée (premier effet).
Il y a un deuxième effet : le décrochage du filtre bleu, qui est lié au décrochage du déschtroumpfage. Comme l'image noire est mal déschtroumpfée, les lignes se trouvent là où elles ne doivent pas être, en particulier les lignes bleues. Comme dans l'algorithme on recherche les lignes bleues à des endroits précis (pas sur toute l'image comme anciennement) mais comme les lignes bleues ne se trouvent pas là où elles devraient être (car l'image est mal déschtroumpfée) : les lignes bleues peuvent réapparaître. Le remède : pour ceux qui ont une grosse configuration, ils peuvent alors augmenter le nombre de "couples".
En attendant que le plugin Albator soit optimisé par Fasouil...

8) Le décodage fonctionne mais le décodeur saute souvent (décrochages par exemple sur le foot). Que faire ?

Première possibilité : La réception est trop mauvaise. Essaiez de l’améliorer : acheter un amplificateur d’antenne, utiliser les câbles les plus courts possibles et les plus neufs possibles, éloigner le plus possible les câbles de l'unité centrale, ne pas utiliser de "tés" dérivateurs... De nombreux décrochages dus à une mauvaise réception peuvent faire un écran noir, et d'autres artéfacts (blocage pur et simple de l'image, augmentation de la luminosité, etc...)

Deuxième possibilité : L'optimisation du plug-in video :
Selon le plug-in que vous utilisez, rendez vous aux sections configs : Meuhmeuhplug, Albator, Cricrac et enfin KAzertix.
De manière générale, on peut dire que plus les réglages seront en faveur de la stabilité, plus la conso CPU sera importante. Attention de ne pas trop pousser les réglages, cela peut entraîner une instabilité et à nouveau des décrochages.
En fait, les réglages que l'on fait poussent à faire le choix d’un compromis entre un décodage fiable et un décodage fluide. Avec le temps, cet adage s'avère de plus en plus faux lorsque l'on voit la fiabilité apportée par les optimisations des algorithmes.

Troisième possibilité : le déschtroumpfage se fait mal à cause des plug-ins de désentrelacement. Selon votre carte graphique (on n’a pas encore fait de liste), les plug-ins de désentrelacement fonctionnent plus ou moins bien. Avec les cartes « récentes » type Geforce ou Radeon, le greedy-2-frame donne des résultats excellents (conso raisonnable et incontestablement la meilleure qualité d’image).
Mais c’est la technique qui consommerait le plus. C’est à vous de voir en essayant patiemment tous les plug-ins et en regardant les facteurs variants cités dans la question 4).


Plug-in Audio - FAQ Son

On a beaucoup de problèmes sur les forums pour faire réussir aux utilisateurs le décodage du son. Avec cette FAQ, si ils ont suivi le Mode d'emploi des plug-ins audio, je vois pas comment on pourrait encore plus les aider…

1) Hachages et décalages dans le temps...
2) Synchro auto son/video
3) Ultime solution...
4) Son codé et décodé en même temps...
5) Problèmes AC97
6) Problèmes Audigy
7) Ca marchait, ça ne marche plus...
8) Son qui grésille
9) Amplification du son

1) J'obtiens des hachages et des décalages dans le temps en décodant. Que faire ?

Tout d’abord, êtes-vous sûr de ne pas avoir le son codé et décodé en même temps ?
Si vous entendez le son codé et le son décodé en même temps, rendez vous à la question 4).
Il faut savoir que si vous êtes sous windows 9x / Me, vous pourrez rencontrer des problèmes de qualité de déschtroumpfage du son, c’est-à-dire ces fameux hachages et décalages dans le temps. Ceci est dû à la gestion du multithread (je ne sais pas ce que c’est) qui est mieux géré sous Windows 2000/XP, les OS sous lequel le soft a été développé.

Essayez de jouer sur le nombre de buffers et la taille des buffers (en les augmentant). Plus le nombre de buffers est bas, et leur taille petite, moins le décodage aura de retard. Par contre, le décodage sera moins fiable et aura plus tendance à être haché. Essayez aussi de jouer sur la priorité, mais ce n’est pas conseillé : une priorité temps réel n’apporte que peu de changements et peut rendre le système instable.

En ultime possibilité, si avec tous les réglages testés, votre son est toujours saturé, vous pouvez modifier la source que vous avez sélectionnée : essayez toutes les sources possibles sans changer les branchements, et refaites ensuite cette manipulation en changeant les branchements : essayez avec le line-in, l’auxiliaire et le microphone.

2) A quoi sert la case "Synchro Auto Son / Vidéo"

Elle ne sert pas comme son nom l’indique à la synchronisation ; elle sert à lancer le décodage automatique du son lorsque le décodage vidéo commence. Ne vous acharnez donc pas à essayer de trouver une différence de synchronisation.
Personnellement, je valide systématiquement cette option qui n'est pas validée par défaut.

3) Malgré tout, je sais, je suis un coucouille, je n’arrive pas à déschtroumpfer.

Si rien ne marche (ce qui ne devrait pas être le cas, a fortiori si vous avez une Sound Blaster et que vous avez suivi tous nos conseils), vous pouvez alors utiliser un décodeur son externe : CPlusWin, et surtout Wilma.
Petite astuce : un script type AutoIt vous permettra de lancer les 2 softs avec un seul double clic et de les fermer tous les deux à la fermeture de l’un ou l’autre. Pour ces softs, référez-vous à la page des liens.

4) J'entends le son crypté et décrypté en même temps. Que faire ?

Si vous avez une Sound Blaster Audigy, rendez-vous à la question 6).
Utilisez la configuration du mixer que propose K!TV (Muet Enregistrement => Source et mettez line-in habituellement). Sinon, allez dans le panneau de contrôle du volume de Windows puis mettez Line-In sur muet. Vous aurez ainsi uniquement le son décrypté.
Pour avoir de nouveau du son sur les chaînes en clair, désactiver l'option muet de Line-In.

Le problème c’est que cela marche normalement automatiquement. Si vous n’arrivez pas à faire marcher le Muet automatiquement, effacez les fichier *.ini de K!TV XP et reprenez l’installation du plug-in Audio ICI.

5) Problèmes avec le chipset VIA AC 97 :

C’est un chipset son de merde intégré aux cartes mères. Effectivement, beaucoup des utilisateurs de plug-in audio sous K!TV se sont arrachés les cheveux à essayer de le faire marcher. Bien souvent, le meilleur conseil qu’on leur ait donné est de racheter une carte son PCI type SB 128 PCI à 25 € chez n’importe quel vendeur informatique. Mais sachez que Cricri, The Real Mc Coy et d'autres utilisateurs bien connus, ont un chipset AC 97 qui fonctionne avec K!TV XP et ses plugins audio.
Voilà ce qu’il faut faire :

Tout d’abord activer la sound blaster dans le bios de la carte mère.
Ensuite, il faut évidemment avoir les bons drivers, c'est-à dire : ou ceux de votre marque de carte mère (pour MSI, il semblerait que ce soit le meilleur choix), ou alors les derniers pilotes fournis par VIA sur leur site. Ce sera à vous de tester, car nous n'avons pas eu assez de retours d'utilisateurs pour tout connaître.
N'hésitez pas aussi à mettre les derniers pilotes VIA de votre carte mère et à la rigueur de flasher le bios. Et les conneries que vous faites, on n'est pas responsable...

Ensuite, suivre entièrement le guide d’installation d'un plugin audio ICI.

Puis, aller dans « Réglages du décodeur audio » et rentrer ces valeurs :

Tout mettre à 25 % en source dans le mixer de K!TV. Mettre X4 dans les réglages décodage son du plug-in Audio ("Amplification du buffer de sortie"), pour une restitution correcte. Ce sont les réglages d'un utilisateur, ils ne sont donc pas forcément idéaux sur toutes les configs.
Il y a aussi beaucoup de problèmes répertoriés, mais non réitératifs.

Pour ceux à qui il reste encore des problèmes :
Chacun y va de sa petite technique personnelle, en tout cas il faut se familiariser avec les différents mixers de son qui sont installés sur votre ordinateur.

Pour beaucoup, c'est à force de manipuler les mixers, et de tout recommencer en supprimant les .ini que cela a fonctionné.
Cricri lui a sa soluss personnelle : il ne faut même pas activer le mixer de k!tv, il faut juste charger le plugin audio, et pour ce qui est du réglage des volumes, jouer manuellement avec le mixer windows.
D'autres utilisateurs ont eu comme solution d'utiliser des drivers plus anciens, et cela a fonctionné. N'hésitez surtout pas à essayer des tonnes de pilotes différents, de VIA ou de la marque de votre carte mère.

6) Problèmes avec la Sound Blaster Audigy : on n’arrive pas à mettre uniquement le son codé en muet (sensation de chuintements, son robotisé, dédoublé, sale)

Installez votre carte proprement, ainsi que le « surround mixer » de creative.

Réglages du Mixer Windows et du Mixer de K!TV XP : pour cela, suivez les consignes indiquées dans le Mode d'emploi des plugins Audio.

Réglages du « surround mixer » Creative :
Sélectionner « Mix ana » comme source « Rec » (si vous n’aviez pas déjà fait cela dans le mixer Windows).
Ne pas « muter » Wave/MP3 ni Entrée ligne
Sélectionner dans le Mode avancé l'onglet EAX et le bouton « paramètres » :
Le Panneau de commande EAX s'ouvre :

Et voilà ce que ça donne :

Dans l'onglet "Source", sélectionner la source "Mix ana" et dans le champ Effet, sélectionner "Son d'origine" et mettre le curseur "Quantité Son d'origine"
- à 0 à chaque passage en son décodé,
- repasser à 100 en son normal

Pas de mute automatique possible :o(
Avis aux développeurs…

7) Alors que Canal+ fonctionnait bien les jours précédents, tout d'un coup aujourd'hui, je n'ai plus de son sur cette chaîne. Pourquoi ?

Un autre logiciel a modifié la configuration SON. On est donc obligé de resélectionner de nouveau la source d'enregistrement qui a changé. Une solution est d'utiliser le soft Quick Mix. Ce soft est utile pour sauvegarder des configurations SON qui fonctionnent bien. On peut ainsi rappeler plus tard la config désirée si le son n'est plus présent à cause de ce mixer de ******.
Autre solution, avec un script type AutoIt, on peut appliquer systématiquement une configuration SON au lancement de K!TV-XP.
Pour ces softs, une seule référence, la page des liens

8) Le son déschtroumpfé grésille !

Aïe, c'est un vrai problème, vous avez des réglages qui ne sont pas adaptés.
Pour améliorer la qualité du son décodé, il est conseillé de régler le volume d’enregistrement du Mixer de K!TV XP sur la valeur la plus élevée possible de manière à obtenir le meilleur rapport signal/bruit possible. Il faudra par contre faire attention à ne pas saturer le canal Enregistrement.
Bip Me conseille lui 80 %, 75 % et 75 % pour les niveaux de volume du mixer de K!TV XP.
Maintenant, plus les valeurs seront basses, moins le son aura tendance à grésiller. Mais moins la qualité du déschtroumpfage sera bonne. De plus, vous rencontrerez le problème de différence de niveau sonore entre votre chaîne déschtroumpfée et les autres chaînes (cf question suivante).
Ce que l'on peut conseiller, c'est d'essayer différents pilotes (par exemple les officiels sur Internet et les pilotes par défaut sur le CD de Windows).
En ultime possibilité, si avec tous les réglages testés, votre son est toujours saturé, vous pouvez modifier la source que vous avez sélectionnée : essayez toutes les sources possibles sans changer les branchements, et refaites ensuite cette manipulation en changeant les branchements : essayez avec le line-in, l’auxiliaire et le microphone.
Les configs différentes faisant énormément varier les réglages, on ne peut vous proposer de valeur de référence.

9) Le volume sonore de Canal+ décodé est inférieur à celui des autres chaînes, comment l'augmenter ?

Utiliser le coefficient multiplicateur : "Amplification du Buffer de Sortie" dans le menu de réglage du plugin audio. On conseille de le mettre le plus bas possible, car il dégrade la qualité sonore, mais le résultat que vous obtiendrez sera spécifique à votre bécane. Il est fonction de vos drivers et de bien d'autres paramètres, on ne peut donc donner de valeur de référence.


Généralités - Installation des plug-ins
On ne le répètera jamais assez : n'essayez pas de faire fonctionner un plugin si vous n'avez pas parfaitement installé K!TV.
Il faut que vous ayez la chaîne sur laquelle vous allez faire fonctionner les plug-ins, avec l'affichage et le son adéquats. Pas la peine d'appliquer de plug-in dans le cas contraire. Faites fonctionner K!TV XP sans plugin avant de vous lancer dans l'aventure !

Première étape : copier les plug-ins (*.dll) dans le répertoire de K!TV XP/Plugins

En théorie, pas besoin d'aide. Vous pouvez aussi installer le aideplugin.chm que vous êtes en train de lire dans le répertoire de K!TV XP/Aide.

Deuxième étape : Ouverture de la bdd "Configuration de K!TV XP..."

Pour cela, 2 techniques :
- Aller dans "BT8x8" => "Réglages..."

- Ou alors cliquer sur l'image avec le bouton droit de la souris (ouverture du menu contextuel)=> "Réglages..."

Troisième étape : Activer les plug-ins dans K!TV XP

- Plugins Vidéo : Ce menu permet de sélectionner un plugin vidéo présent dans le répertoire de K!TV XP, une fois que la liste a été rafraîchie.

- Plugins Audio : Ce menu permet de sélectionner un plugin audio présent dans le répertoire de K!TV XP, une fois que la liste a été rafraîchie.

- Appliquer : Enregistre la sélection d'un plugin.

- Rafraîchir : Crée la liste des plugins disponibles dans le répertoire de K!TV XP : ceci n'est nécessaire que lorsque l'on vient de copier un plug-in dans la racine de K!TV XP.


Généralités - Introduction

K!TV XP est une application de télévision freeware (et 100 % légale) pouvant remplacer avantageusement celle livrée avec votre carte télévision. Cette application fonctionne à partir d'une carte télé avec un chipset de type BT8x8, c'est-à-dire BT848 ou BT878.
Elle possède de nombreuses particularités (se référer à l'aide officielle), et parmi elles celle d'accepter des plug-ins sonores et vidéos.

Un plugin est un fichier *.dll que K!TV fait fonctionner parallèlement à l'application, en vue de traiter le signal vidéo ou sonore avant de le ressortir sur le PC.
Cette aide va se borner à présenter les plugins qui existent pour la version actuelle de K!TV XP. Il ne nous a pas semblé nécessaire de parler des versions antérieures de K!TV et de ses plugins, les versions les plus récentes ayant surpassé dans tous les domaines leurs prédecesseurs.

Liste des plug-ins existants pour K!TV XP

Plug-ins audios | Chorus.dll | c'est un plug-in audio servant universellement au déschtroumpfage du son.
 | KiwiCricri.dll | c'est un plug-in audio servant universellement au déschtroumpfage du son.
Plug-ins vidéos : | Albator.dll | c'est un plug-in vidéo servant au déschtroumpfage de Canal + en secam.
 | Albator707.dll | idem à albator.dll, mais plus ancien : grincheux a laissé dans ce plug-in les lignes de code de la version de K!TV v 0.7.0.7. (du temps où il n'était pas plug-inisé) avant qu'il apporte sa touche personnelle (albator.dll). Une sorte de backup, donc.
 | Meuhmeuhplug.dll | tout comme les albator, ce plugin (basé sur les algos de fasouil) sert au décodage du Nagra, codage de canal+ en secam.
 | Cricrack.dll | c'est un plug-in servant au déschtroumpfage de Canal + codé en Discret (FTC analogique et Canal + Belgique).
 | KAzertix03.dll et KAzertix04.dll | (développement arrêté) : ce sont des plug-ins (avec des algorithmes différents) servant au déschtroumpfage de Canal + codé en Discret (FTC analogique et Canal + Belgique).
 | KAzertix02.dll | (développement arrêté) : plug-in servant au déschtroumpfage de la RAI (uniquement en Belgique). Attention, on parle là de la RAI non FTC.
Plug-in d'enregistrement : | ZoomoutKTV | (version en bêta test) : merci à zoomin

Quel plug-in et quelle clé utiliser ?
Faisons un tableau récapitulatif :
ces informations ont été glanées un peu partout sur les forums, si vous en avez d'autres, n'hésitez pas à nous le faire savoir sur un des forums de la page des liens

Pays | Signal | Plug-ins | Clé | Notes spéciales
France | Canal + via le satellite (Telecom) | Albator ou Meuhmeuhplug | Key_c.txt | On la trouve dans Multidec. Il faut la renommer en Key.txt sous peine de Blanche-Neige.
 | Canal + en Hertzien, Canal + via le câble UPC |  | Key.txt | Réaliser une recherche auto des canaux.
Suisse | Câble, Nagra |  |  | Le signal codé est en Secam (et en Pal lorsque c'est en clair).
Antilles | C+ Antilles par le câble MTVC |  |  | Réaliser une recherche auto des canaux.
 | Canal + en Hertzien |  |  | Canal : 502.750
Belgique | Signal analogique codé en Discret | Cricrack Kazertix 03 Kazertix 04 | Aucune clé nécessaire, (modifiable dans Criccrac.ini | Le principe est le vieux système discret, également encore utilisé en Belgique, basé sur les décalages de 880 ns en début de ligne.
France | FTC (France Télécom Câble)
Belgique | chaîne Rai uniquement en Belgique (et non FTC) | Kazertix 02 |  | Décodage par clé (polynome) uniquement pour la chaîne RAI en Belgique.

Voilà, c’est tout ce que je sais. Avant de vous plaindre de problèmes de décodage tels que grosse saccades, images décalées à demi décodées, ou images non décodées, soyez sûr d’utiliser la bonne clé et le bon plug-in.


Pour finir ... - Liens

Le site officiel de K!TV (et 100 % légal) | http://www.kastortv.com
Le seul et unique forum Dévelo (seulement des remarques aux développeurs, pas de questions...) | Forum Dévelo
Le forum Généraliste (toutes les questions que vous vous posez sur l'utilisation des softs télé) | Forum Gagai
Une page où on trouve tous les plug-ins ainsi que leurs sources | La page de cricri
Le tableau des liens vers les autres logiciels | Tableau des liens du forum GAGAI
La page de news du forum DEVELO (très active) | Les News du forum DEVELO
Le Patch PCI Latency de George Breese | VIA PCI Latency Patch
Le Patch PCI VIA (copié du patch de George Breese) | Patch PCI VIA
Le Patch PCI Pinnacle | Patch PCI Pinnacle
Le logiciel WinTop (visionneur des ressources CPU sous Windows 9x/Me) | WinTop ou WinTop chez microsoft.com
Wilma (meilleur soft externe de décodage du son) | Wilma
AutoIt (logiciel de création de scripts, ou commandes automatisées) | AutoIt
QuickMix (soft pour appliquer automatiquement des réglages du mixer windows) | QuickMix


Pour finir... - Remerciements

Tout simplement à la famille des Schtroumpfs ;o) :

Les autres resteront anonymes et pis c'est normal.

Ce qu'il faut dire, c'est que beaucoup de bénévoles,
et même des non-programmeurs,
aident au développement de la scène NAGRA.
Pourvu que ça dure !
Soyons présents sur les forums, polis, calmes,
échangeons nos idées entre personnes qui ont cherché
et trouvé des petites remarques à faire.

Car s'il ne doit rester qu'un maître dicton :
l'entraide est notre force à tous !


Plug-in Audio - Mode d'emploi

Tout le monde peut y arriver !!!! M’étant baladé un peu sur tous les forums de décodage canal+, je me suis rendu compte que beaucoup de gens croient que ce n’est pas possible de décoder le son avec K!TV XP. Mais si ! Et tout le monde peut le faire ! Cette page va vous aider à faire ça bien, parce que selon moi, les plug-ins audio associés à K!TV XP valent les meilleurs décodeurs sonores.

La partie théorique :

Le son sort du tuner télé « brut », c’est à dire que de la carte sort un son non modifié par l’ordinateur. L’ordinateur reçoit cette entrée son de différentes possibilités : par le line-in de la carte son, par la prise auxiliaire interne de la carte son ou par l’entrée microphone de la carte son. C’est la manipulation que vous avez faite pour faire marcher le son sur votre tuner télé. Là, c’est clair.

On sait que le son passe par la carte son pour être redirigé vers les enceintes. Là, il n’est pas modifié, et la carte son sert juste d’intermédiaire transmetteur du signal.

Oui, mais on peut détourner ce flux et le faire passer dans le moulin à café qu’est le processeur (en partenariat avec un plug-in Audio niark niark). Ca s’appelle la capture : l’ordi enregistre le son, le modifie à souhait (hihihi) et le rebalance en son wave que la carte son va rebalancer vers les enceintes. En un rien de temps évidemment. C’est le petit retard que vous aurez entre le son et l’image décodée chez K!TV XP, car on ne retarde pas l'image par contre.

Il y a donc 2 trajets différents, un direct et un indirect. C’est ce trajet indirect qui est dur à configurer, parce que windows sélectionne un mauvais trajet par défaut et que K!TV XP ne sait pas le modifier sans notre aide.

La petite manipulation :

1ère étape : avoir le son codé.

Lors du premier lancement de K!TV XP, il va falloir s’assurer que le périphérique audio de K!TV est activé et piloté, et configurer la capture du son. Cela se fait à plusieurs niveaux, dont le réglage du mixer.
Il ne faut pas que vous ayez de plug-in actif si vous réalisez cette manipulation ! Si vous n'en êtes pas à votre premier lancement, ou si certains plug-ins étaient activés, supprimez K!TV-XP.ini du répertoire de K!TV XP.

Pour ouvrir la fenêtre du mixer, allez dans la bdd "Réglages", onglet "Audio / MSP" et cliquez sur la case "Réglages du mixer".

Voici la fenêtre du mixer telle qu'elle apparaît avant configuration :

Il est nécessaire d'activer Périphérique audio activé et piloté puis de cliquer sur OK. K!TV XP va alors récuperer un certains nombre de paramètres propres à votre système et à votre carte son. Enfin la fenêtre suivante apparaît.
Suivant la carte son, le menu peut différer. Ici l'exemple est fait avec une carte Sound Blaster Live! PCI.

Périphérique : correspond aux différents périphériques sonores configurables. Si vous possédez une seule carte son, il n'y aura qu'un seul choix. Sinon il y en aura autant que de cartes son.

Contrôle du volume : Lecture. Cela correspond à l'entrée sonore de la carte son sur laquelle le son de la carte TV est redirigé. La plupart du temps, quelque soit la carte, un petit câble son sort de la carte TV et est inséré dans une entrée de la carte son, le "Line-In" ici (ou "Entrée de Ligne" ou simplement "Ligne").

Il est possible de régler le niveau sonore par le curseur et de forcer à Muet ce canal (cela peut servir lors d'un appel téléphonique ou autre et peut aussi être activé par le raccourci clavier "M")

Capture : Enregistrement - Wave : Pour certains traitements sonores, (plugins audio par exemple), il peut être intéressant de capturer (enregistrer) le son puis de le restituer sur un autre canal (Wave). Il est conseillé de régler sur la valeur la plus élevée possible de manière à obtenir le meilleur rapport signal/bruit possible. Il faudra par contre faire attention à ne pas saturer le canal Enregistrement. Le curseur Wave (signal de monitoring) peut être mis lui aussi à la valeur la plus élevée possible avant saturation (ici 100%). Bip Me conseille comme réglages 80 % et 75 % .

Les 2 sources (Lecture et Capture) doivent être identiques, c’est-à-dire :

- line-in pour ceux qui branchent la sortie son de la carte télé à l’entré son de la carte son via un cable jack
- auxiliaire (aux) pour ceux qui relient les 2 cartes par un cable interne

On pourra aussi essayer de relier la carte télé avec l’entrée microphone de la carte son, pour ceux qui ont des problèmes de déschtroumpfage avec l’entrée line-in.

2ème étape : Activer le plug-in audio dans la boîte de réglages (rendez-vous ICI pour cela)

Vous avez maintenant la fonction "Décodage" "Réglage du décodeur audio" présente dans le menu contextuel de K!TV XP (bouton droit). Oui, mais ne touchez pas aux réglages, ils sont là pour modifier la qualité du déschtroumpfage, on verra ça plus tard… Si ça vous intéresse, rendez vous aux pages de configuration de chacun des plug-ins audio.

3ème étape : S’assurer que la source d’enregistrement est bien sélectionnée.

Alors c’est là que le problème se situe. Le problème est bien connu des développeurs : le mixer K!TV XP présente une grosse lacune, c’est qu’il ne sait pas modifier les paramètres de la carte son tout seul. Il faut l’assister manuellement. Et c’est le problème que l’on rencontre le plus fréquemment, la source d’enregistrement par défaut étant le microphone.

Donc il faut aller modifier ce paramètre manuellement dans le mixer windows.

Qu’est-ce que le mixer windows ? Allez, je vous montre deux screenshots :

Vous voyez, c’est le hp noir sous win xp.
Et c’est le hp jaune sous win 98.
Comment posséder cet HP ? Aller dans le « Panneau de configuration » => double-clic sur « Sons et périphériques audios » et là l’option s’offre à vous de « Placer l’icône de volume dans la barre des tâches ».

Le petit hp donne cette fenêtre lorsque vous double-cliquez dessus :

Notez que vous pouvez ouvrir aussi cette fenêtre via : « Démarrer » => « Programmes » => « Accessoires » => « Divertissement » => « Contrôle du volume ». Le mixer Windows est présent à partir du moment où vous possédez une carte son. S’il n’y est pas, vous n’avez pas de carte son installée.

Bon, ça c’est bien, là vous voyez que l’entrée ligne n’est pas muette : quand vous décoderez, il faudra qu’elle y soit : si vous n'y arrivez pas, il faudra voir les FAQ Son.

Mais ces paramètres sont ceux de lecture et non ceux d’enregistrement.

Faites « Options » « Propriétés » , vous cochez « Enregistrement » et les cases qui nous intéressent. Comme ça :

Faites « OK » et maintenant vous avez ça :

Oups, j’ai pas l’auxiliaire. On fera avec. Et là vous avez vu, j’ai sélectionné line-in (Entrée Ligne) en tant que source d’enregistrement, (la source d'enregistrement est appelée Wave In par le mixer windows). Car moi j’ai branché la source son sur l’entrée ligne de ma carte son (faites en fonction de vos branchements, ceci est un exemple).

6ème étape :

Vous venez de faire le plus dur ! Vous lancez K!TV XP, vous vérifiez encore une fois dans le mixer K!TV XP que tout est bien réglé (il arrive qu’il se dérègle au bout de beaucoup de plusieurs manipulations, ainsi qu'en utilisant d'autres softs), là vous vous mettez sur la chaîne codée, vous entendez le son codé, et vous appuyez sur F4 (touche du décodage audio). Si tout se passe bien, c’est gagné.

Vous pouvez maintenant aller modifier les réglages du son dans la boîte de réglage de votre plugin audio pour rendre le décodage audio automatique, et faire varier la qualité du décodage.

Pour d'autres utilisateurs (par exemple ceux sans carte son Sound Blaster), il se peut qu'il y ait malgré tout des problèmes. Ils peuvent essayer de le solutionner avec la FAQ Son.
Pour quelques infortunés qui n'y arrivent toujours pas, ils peuvent en dernier recours utiliser un décodeur son externe.
Les meilleurs logiciels sont CPlusWin, et surtout Wilma (voir la page des liens). On ne saura mieux conseiller aux gens qui rencontrent des difficultés que d'achter une carte son sound blaster (sb128 pci à moins de 30 €).


Plug-in Vidéo - Fix chipset VIA

Explications du VIA Fix
 Made by TG, modifié par superwan

1) Qu'est-ce que ce problème du chipset VIA ?

Grande question. En pratique courante, le "problème du chipset VIA" correspond à la présence sur l'image décodée par un plugin video de lignes noires qui apparaissent et disparaissent très rapidement et qui rendent ainsi l'image décodée super moche. Mais pour cela, l'image doit être en mode FF (mode Full field, "décoder les 2 trames", touche TAB), car c'est à ce moment que les bandes passantes sont le plus saturées.

Voici l'image que ça donne ("Spartacus" avec Kirk Douglas) :

Le deuxième problème (beaucoup moins gênant et présent dans la pratique) apparaît dés la consultation d'une chaîne classique et avec tous les logiciels (MoreTV, Tview, Amcap...). Les images en clair font apparaître un effet de rémanence des trames (du genre sur-entrelacement).

Pour résumer, ce sont donc des artifacts qui apparaissent sur l'image, retrouvés sur beaucoup de configurations très différentes, dont les causes sont multiples, et qui forcent à de nombreuses techniques pour être résolus.

2) Quelle est la cause de ce problème ?

En théorie, le problème est matériel et est dû à une saturation des bus mémoire, PCI, et/ou AGP, qui crée des artifacts sur l'image, et cela parce que K!TV XP nécessite une large bande passante au niveau du bus PCI pour les transferts carte TV => mémoire centrale => carte graphique.
On a longtemps pensé que c'était dû aux cartes mères à base de chipset VIA (d'où le nom), mais ce ne serait pas le seul facteur qui rentre en compte.
Dans l'aide de k!tv xp, il est dit que ce problème apparaît spécialement pour les personnes utilisant leur matériel à des fréquences non officielles (100 ou 133 MHz) et ceux ayant recours à la désynchronisation FSB/Mémoire.

A propos du chipset VIA :
Il semble que VIA n'ait pas respecte totalement et correctement les normes PCI et des corruptions apparaissent lors de fortes sollicitations du bus PCI (transferts IDE, USB, PCI).
Les cartes mères à base de contrôleur (chipset) VIA telles que KL133, KLE133, KX133, KT133 x, KT266 x, etc... ont parfois quelques difficultés à gérer d'importants flots de données en transit via les bus PCI, le bus mémoire et parfois le bus AGP. Ceci semble dû à une conception un peu rapide de ces chipsets et bien qu'ils vérifient les spécifications des différents BUS (PCI, AGP, RAM), les caractéristiques n'ont pas assez de marges par rapport aux spécifications.
Néanmoins, certaines cartes à base de chipsets VIA n'ont pas de problème et il semble donc que ceux-ci soient fonction du design de la carte. Un design novateur (ABIT) aura probablement plus de problèmes qu'un design robuste (ASUS, MSI). Ainsi pour les cartes à base de KT133A, il semble que les ASUS A7V133 ne posent pas de problème alors que les ABIT KT7A en posent énormément. Pour les CM à base de KT266A, la MSI K7T266PRO2 est une véritable perle.

De plus, voilà ce qu'on peut trouver comme informations :
"Un bug AMD fait de nouveau parler de lui. Le bug PSE/AGP qui touche l'Athlon et le Duron a d'une certaine manière été "redécouvert" par les utilisateurs de Linux. A titre de rappel, ce bug provoque des corruptions dans la mémoire vidéo utilisée par l'AGP, et ce lorsque l'OS active le mode de pagination étendu (Page Size Extension). Le résultat est un plantage du système sous certains programmes utilisant intensivement le bus AGP. AMD s'est bien entendu empressé de sortir un patch contournant le problème (en interdisant tout simplement l'utilisation de la pagination étendue), patch nommé à juste titre "Windows 2000 patch for AGP application". Il est à noter que ce bug touche les gammes Duron, Athlon, et Athlon XP (sauf le dernier stepping A5) sous Windows NT et 2000 (Windows XP incluant déjà le patch)."
Avec un Athlon XP 1700+ rev A5, on n'a effectivement pas de problème de lignes pourries... et malgré un chipset VIA. Les artefcts bug pourraient être engendrés aussi par des processeurs amd...

On sait qu'améliorer les performances de sa carte mère peuvent aussi apporter des solutions.

Ce qu'il faut retenir, c'est que ces parasites ont de nombreuses causes complexes, et que chaque cas est spécifique. De plus, les performances d'une machine varient d'un jour sur l'autre selon qu'on la chauffe un peu ou pas.

3) Voici la liste des moyens qui s'offrent à nous pour résoudre ce problème :

- Mettre à jour les drivers de sa carte mère
- Le Patch PCI VIA qu'on trouvera sur le site de VIA (voir le 4) )
- Le George's PCI latency patch (équivalent du patch PCI VIA) (voir le 4) )
- Le patch Pinnacle censé améliorer les performances PCI (voir le 5) )
- Le boostage du bios de sa carte mère au niveau du bus PCI (voir le 6) )
- Et évidemment le "Fix chipset via" (voir le 7) )

4) 1ère solution : les patchs PCI (PCI latency patch de George Breese et Patch PCI par VIA)

Ces patchs servent, comme leur nom l'indique, à améliorer sensiblement les transferts PCI. Pour les télécharger, rendez vous à la page des liens. Attention certains (dont Quenotte) semblent avoir eu quelques problèmes de stabilité avec le patch de George Breese, mais la qualité du développement de ce patch (on en est à la version 0.19d et le patch est sans cesse amélioré) peut faire penser à une instabilité autre du PC.
En tout état de cause, ce patch peut être facilement désinstallé en mode sans échec, donc l'essayer ne devrait pas poser de gros problèmes.
A noter que VIA a, au bout d'un bon bout de temps, reconnu que ses chipsets avaient des pertes de perfs, et a donc mis à dispo sur son site un patch PCI du même acabit.

5) 2ème solution : le patch Pinnacle

Pinnacle a développé un petit logiciel visant à améliorer les transferts PCI. Il a été testé avec du matériel non Pinnacle avec succès (Hauppauge). Cela ne fait pas partie des drivers Pinnacle. C'est juste un utilitaire visant à améliorer les transferts PCI.
Pour le télécharger, rendez vous à la page des liens.

6) 3ème solution : optimiser sa carte mère en utilisant les timings les plus agressifs possibles

Ce qui suit montre les différentes étapes auxquelles j'ai eu recours pour avoir un K!TV XP au plus haut de son art. Ma config est dans l'aide de K!TV (c'est celle de TG) et le lecteur concienscieux pourra voir que je suis équipé d'une ABIT KT7A qui est LA carte à problèmes.

Pour la Abit KT7a :
Abit, c'est peut-être buggué, mais vus les BIOS ABIT, il y a moyen de débugguer leurs cartes.
En jouant dans le bios, vous optez pour une solution qui certes permet aussi parfois de résoudre d'autres problèmes (usb, cartes sons), mais attention, vos conneries ça n'engage en rien l'auteur de ces lignes, on ne pourra être tenu responsable de vos conduites dangereuses ni de vos conduites irresponsables.

Maintenant que c'est dit :
Dans la section soft menu III, modifier les réglages suivant :

Enhance Chip Performance -> Enabled
Force 4-way Interleave -> Enabled
Enable Dram 4k-page Mode -> Enabled

et pour ceux qui ont un processeur en BUS 100 MHz (Duron et Athlon Tbird "B")
DRAM Clock = HCLK + PCICLK ; c'est-à dire que le FSB est à 100 MHz, le PCI à 33 MHz, le bus mémoire est désynchronisé et tourne à 133 MHz (avec de la Ram PC133 évidemment.

Avec ces réglages, le FF passe parfaitement SANS Via Fix (ce qui étonnait Quenotte lorsque nous en avions parlé).

Notes sur le réglage Enhance chipset performance
Sur le guide d'utilisation de la KT7A, on peut lire :
Si vous choisissez "Enabled", les différents timings du chipset north bridge seront paramétrés de façon plus agressive pour de meilleurs performances.
Or le northbridge VT8363A fait interface avec le processeur, la mémoire, la carte graphique AGP et les périphériques PCI (cf. HFR). Donc, il est possible que les échanges PCI => RAM / RAM => AGP se passent mieux en boostant le N/B.

Voilà ce qu'en dit la FAQ non officielle des cartes KT7x : This should be enabled for improved performance and disabled for improved stability. It enables more aggressive timings for the processor. On my machine when enabled this option improved my ALU Memory Bandwidth score in Sandra 2000 by about 5%. The CPU Benchmark, Multimedia Benchmark and FPU Memory Bandwidth were unchanged.

Sur www.athlonoc.com, il est dit :
Enhanced Chip Performance, This feature increases the performance of your Duron or Thunderbird Processor.

Sur www.usbman.com :
The Abit KT7 with Award BIOS has a BIOS feature setting "Enhance Chip Performance" . Setting this option to Enabled solves many USB related problems. According to the manual this setting which is Disabled by default improves performance by modifying timing on the motherboard's North Bridge.

Asustek :
Pour infos, j'ai monté un PC avec une ASUS A7V133-c (le KT133A de chez ASUS) il y a quelques mois. Les réglages ne sont évidemment pas identiques mais dans le BIOS on trouve deux réglages interessants : "DRAM clock" et "System performance settings".
Renseignement pris ici pour ce dernier : ftp://ftp.asus.com.tw/pub/ASUS/mb/socka/kt133a/a7v133-c/a7v133(-c)_105.pdf
This function controls settings related to system memory performance. When [optimal] is selected, DRAM bank interleave, 4K page, and burst refresh will be enabled to boost system performance.

Par défaut le réglages est à [optimal] et cela devrait aider cette excellente carte Asus.

Et pour les autres cartes mères ?
Bah pour les autres (MSI, EPOX, DFI...), ben moi chui pas assembleur alors à vous de trouver des infos...
En gros, vous l'aurez compris, il faut booster dans le bios de la carte mère les réglages du PCI, de l'AGP, et de la mémoire. Et ne pas la griller.
Pour tous ceux qui ont des infos pour ne plus utiliser ce "fix chipset VIA", nous les remercions d'avance de faire part de toutes les informations utiles sur le Forum Dévelo (voir la page des liens).

7) L'ultime solution : le "Fix Chipset Via"

Règle n°1 : Il détériore la qualité de l'image, ne l'activez donc pas si vous n'avez pas ces problèmes.
Règle n°2 : Si vous avez les problèmes décrits en 1), c'est-à dire si vous avez ces petites lignes qui clignotent, elles peuvent fortement augmenter la conso CPU ; vous devriez donc activer le fix chipset via.

Comment fonctionne-t-il ?
Quenotte a eu l'idée de réduire la taille du flux vidéo à traiter. C'est le VIA Fix.
Son fonctionnement est assez simple.
Prenons une image complète : celle ci compte 768*576 pixels. On observe généralement que c'est le nombre de lignes qui donne la qualité de l'image. Si l'on ne veut pas trop dégrader l'image, on va réduire le nombre de pixel sur une ligne, par exemple 638*576. On gagne près de 20 % de place mémoire ce qui se traduit pas une diminution sensible de la bande passante nécessaire. Cette explication simpliste illustre l'intérêt du VIA fix.

Mais quelle est la différence avec la "Capture, résolution en X" réglable dans K!TV ?
Bah y en a pas, sauf que le "fix" ne s'active que lorsque le plugin video est actif, donc uniquement sur la chaîne que vous voulez décoder. Car on rencontre plus de problèmes avec une chaîne que l'on décode qu'avec une chaîne que l'on ne décode pas.

Ce fix est en tout cas efficace sur tous les problèmes rencontrés, mais au prix de la détérioration de l'image.

Comment régler le "Fix Chipset Via" ?
Jouez avec la valeur du Via Fix, en sachant que plus la valeur est élevée, moins le fix agira, et moins l'image sera détériorée, mais moins les lignes s'en iront.
Le meilleur réglage est donc le réglage le plus élevé pour lequel on ne rencontre pas de problème. Attention, si vous arrivez à aller jusqu'à 768, ça ne sert à rien d'utiliser le fix.

Un petit screenshot du Via Fix en action (et toujours le "Spartacus" avec Kirk Douglas) :

On a essayé de mettre en évidence tout ce qu'on savait, en espérant que cela serve. Merci à TG pour une grosse partie du texte.